Technical Issue in Billing System 20231218

Incident Report for SalmonCloud

Resolved

We recently encountered a technical problem in our billing system related to one of the third-party software solutions we use, which causes the following errors when an order contains more than one instance:

1. Only the first instance in the order is set up after the payment is received. The remaining instances won't be set up automatically by the system.
2. The next due date of the remaining instances are set to the date of order instead of the date after one billing cycle.
3. When customers put an order of multiple instances, they may encounter an error screen after payment.

The aforementioned errors can be manually corrected on our side.

Update on 4 May 2024:
We have fixed the bug in the third-party integration module, and have submitted the code fix to the said company so that other users of their product could benefit from the fix as well.
Posted Dec 18, 2023 - 17:05 UTC